Solving npm WARN engine cordova-js@3.8.0: wanted… warning

If you encounter the following warnings or similar when you attempt to install Apache Cordova, you can perform one of the suggested two options to resolve this warning.

C:\>npm install -g cordova
npm WARN engine cordova-js@3.8.0: wanted: {“node”:”~0.10.x”} (current: {“node”:”
0.12.0″,”npm”:”2.5.1″})
npm WARN engine npm@1.3.4: wanted: {“node”:”>=0.6″,”npm”:”1″} (current: {“node”:
“0.12.0”,”npm”:”2.5.1″})
npm WARN engine xmlbuilder@2.2.1: wanted: {“node”:”0.8.x || 0.10.x”} (current: {
“node”:”0.12.0″,”npm”:”2.5.1″})
C:\Users\Neelabh\AppData\Roaming\npm\cordova -> C:\Users\Neelabh\AppData\Roaming
\npm\node_modules\cordova\bin\cordova
cordova@4.3.0 C:\Users\Neelabh\AppData\Roaming\npm\node_modules\cordova
├── underscore@1.7.0
├── q@1.0.1
├── nopt@3.0.1 (abbrev@1.0.5)
└── cordova-lib@4.3.0 (valid-identifier@0.0.1, osenv@0.1.0, properties-parser@0.
2.3, bplist-parser@0.0.6, mime@1.2.11, unorm@1.3.3, semver@2.0.11, shelljs@0.3.0
, dep-graph@1.1.0, rc@0.5.2, elementtree@0.1.5, xcode@0.6.7, d8@0.4.4, glob@4.0.
6, npmconf@0.1.16, through2@0.6.3, init-package-json@1.3.0, request@2.47.0, tar@
1.0.2, plist@1.1.0, cordova-js@3.8.0, npm@1.3.4)

The above error is due to Node.js 0.12.X which was released recently.

Option 1:

Run the following

npm install -g cordova@4

to force npm installing the newer version. Cordova 4 works with both 0.10 and 0.12 Node.js version.

Option 2 (preferred option):

Downgrade your Node.js installation to 0.10.X.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: